[OS X TeX] a problem with MacTex 2009

Herbert Schulz herbs at wideopenwest.com
Mon Nov 16 18:00:14 EST 2009

On Nov 16, 2009, at 4:42 PM, Shengchao Qin wrote:

> Thanks. Yes, the problem is solved after I downloading the unix version of the espcrc1.sty.
> I got another problem: it seems the typeset command always use 'pdflatex'. My tex file has some .eps
> figure and the pdflatex stopped at the .eps place (error message given below). It worked in windows where I use latex (Miktex) not pdflatex. Is there a solution to this problem? Thanks.
> ! Package graphics Error: Division by 0.
> See the graphics package documentation for explanation.
> Type  H <return>  for immediate help.
> ...                                              
> l.9 \includegraphics{./overview.eps}}
>                                     \vspace*{-3mm}\caption{Our Approach to ...


What editor are you using? If you're using TeXShop you need only check Typerset->TeX and DVI and latex->dvips->ps2pdf processing will take place for that session. You can make that the default processing method by choosing TeXShop->Preferences->Default Script->TeX + DVI and that will be used by default from then on. Finally, if you place the line

% !TEX TS-program = latex

at the top of your tex file the latex->dvips->ps2pdf processing will be used for that file no matter how the default is set. Substitute `pdflatex' or `xelatex' for `latex' to use that for the file. There are also lots of other engines available; see the files in ~/Library/TeXShop/Engines/Inactive/ for more information (~ is your HOME directory).

If you drop the eps file onto TeXShop it will be converted to a pdf which you can use with pdflatex (leave off the eps extension in the \includegraphics{...} command). Finally, if you add \usepackage{epstopdf} the eps file will be transformed into a pdf on the fly (assumes that shell-escape is enabled).

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the MacOSX-TeX mailing list