[OS X TeX] Linux --> Mac: Beamer and "Non-PDF special ignored!"

Luis Sequeira lfsequeira at gmail.com
Thu Sep 23 04:36:37 EDT 2010

On Sep 22, 2010, at 8:00 PM, <macosx-tex-request at email.esm.psu.edu> <macosx-tex-request at email.esm.psu.edu> wrote:

> I am a long-time LaTeX user on Linux platforms, and now have a brand new
> Mac, with a fresh install of MacTeX/TexLive 2010.  I took an existing Beamer
> presentation (one that works fine in Linux) and tried compiling it (with
> pdfLaTeX), and got a slew of "Non-PDF special ignored!" errors, and the
> \visible commands weren't functioning properly in the PDF (every component
> woud be uncovered for every PDF page in the slide).  But in attempting to
> isolate the problem, I found the following is sufficient to produce the
> errors:
> \documentclass{beamer}
> \begin{document}
> \begin{frame}
> \end{frame}
> \end{document}
> This produces about 100 "Non-PDF special ignored!" errors, with no other
> enlightening errors in the output or the log.  Behavior is the same from the
> command line or TeXworks.
> Searching elsewhere suggests this is a pdfTeX problem, but hasn't given me a
> clue about the cause or a solution.  I'm baffled how something so common
> could go so completely wrong.  FWIW, the pdfTeX version listed in the output
> is 3.1415926-1.40.11, while in Linux, a successful compile runs with the
> output declaring pdfTeXk, Version 3.141592-1.40.3.
> Any suggestions would be greatly appreciated.  This is the last step in
> converting this silvery paperweight into a useful scientific computing
> device.
> Rick

I tried your minimal example in a new file and it produced no such errors. I am using MacTeX 2010 and typeset from TeXShop.

The "Non-PDF special ignored!" errors are usually the consequence of trying to use some code that requires postscript, and that therefore code that should be typeset using latex+dvips+ps2pdf rather than pdflatex - which, when using TeXShop, can be easily achieved: either select "TeX and DVI" under the Typeset menu, or (my preferred method) specify it on a document basis by entering a line containing "%! TEX TS-program = latex" (without the quotes) near the top of the source file.

Why then, does this still happen on your very minimal example, that does not use pstricks or anything else? My guess is that you may have an old .aux or other ancillary file lying around that is causing this.
Say your test file is named test.tex; then try removing all test.aux, test.out, test.log etc (you may do it from within TeXShop itself with File->Trash Aux Files, but I am not sure if TeXShop knows all the file extensions of files that beamer creates - .out, .nav, .snm are some of them; you should clear them all, just in case).
I suppose that if you then try again, the errors will not reappear. If I am right, problem solved; if not, then there may be some other conflict that will require more troubleshooting.

Luis Sequeira

More information about the MacOSX-TeX mailing list