[OS X TeX] MacTeX 2014 TeX Distribution panel broken under Mac OSX Yosemite RC

John Minter jrminter at gmail.com
Sun Oct 5 13:47:31 EDT 2014

I just upgraded my MacBook Pro from Mavericks to the Mac OSX 10.10 Yosemite
release candidate. My son had no issues and it gave us access to some
iCloud features that were rolled out on our iPhones and iPads, so I gave it
a try. I ran into a couple of MacTeX 2014 issues (and found workarounds)
that I thought I should report since the Yosemite release is scheduled soon
(Oct 16 IIRC).

1. The TeX distribution panel is broken. It shows up in the System
Preferences but when you click on the panel, it gives an error message:
"Could not load preference panel."

2. Because this was an upgrade install, MacTeX was already symlinked into
/usr/texbin. I am not sure whether that would be a case with a clean
install. I should that the OS upgrade hung for well over an hour at the 2
min left point. Turns out it was copying files from /usr/local (TexLive and
homebrew) from a recovery partition back to /usr/local. Cmd-L  lets you see
this in the log. I mention this because I suspect those of you who do
upgrade installs will likely encounter this and might be concerned (as I

3. I tried a re-install of MacTeX 2014 and there was no error from the
installer. I updated the packages and checked the preference pane again.
Again it failed to load.

4. I use RStudio to process Sweave documents that embed R chunks with
LaTeX. RStudio could not find the LaTeX distribution. TeXworks could, but I
had configured it previously. It turns out that this Yosemite beta/RC has a
known problem passing environment variables to processes. The apps never
read the bash environment from .profile but one used to be able to use a
csh syntax and set environment variables in /etc/lauchd.conf that many apps
read/find. This does not now work for RStudio or another application
(ImageJ) that I use. I did find a workaround - I can set the path and
environment variables directly via launchctl from a bash shell script. Here
are a couple of lines from the script in case it helps someone

# fix-yos.sh
launchctl setenv PATH
launchctl setenv GIT_HOME /Users/jrminter/git

I run the fix-yos.sh from terminal prior to launching a problem application
and my applications work.

Hope this helps others.

John Minter
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://email.esm.psu.edu/pipermail/macosx-tex/attachments/20141005/a3c23042/attachment.html>

More information about the MacOSX-TeX mailing list