[OS X TeX] MacTeX 2014 TeX Distribution panel broken under Mac OSX Yosemite RC

Herbert Schulz herbs at wideopenwest.com
Sun Oct 5 14:14:08 EDT 2014

On Oct 5, 2014, at 12:47 PM, John Minter <jrminter at gmail.com> wrote:

> I just upgraded my MacBook Pro from Mavericks to the Mac OSX 10.10 Yosemite release candidate. My son had no issues and it gave us access to some iCloud features that were rolled out on our iPhones and iPads, so I gave it a try. I ran into a couple of MacTeX 2014 issues (and found workarounds) that I thought I should report since the Yosemite release is scheduled soon (Oct 16 IIRC).
> 1. The TeX distribution panel is broken. It shows up in the System Preferences but when you click on the panel, it gives an error message: "Could not load preference panel."


I'm not running the Yosemite preview so take what I say with a grain of salt.

This is a know problem. It might be related to the environment problem you noted below but I'm certainly not sure.

> 2. Because this was an upgrade install, MacTeX was already symlinked into /usr/texbin. I am not sure whether that would be a case with a clean install. I should that the OS upgrade hung for well over an hour at the 2 min left point. Turns out it was copying files from /usr/local (TexLive and homebrew) from a recovery partition back to /usr/local. Cmd-L  lets you see this in the log. I mention this because I suspect those of you who do upgrade installs will likely encounter this and might be concerned (as I was)...

I've seen one other report of this behavior. How come texlive and homebrew are on a recovery partition?

> 3. I tried a re-install of MacTeX 2014 and there was no error from the installer. I updated the packages and checked the preference pane again. Again it failed to load.

Noted above.

> 4. I use RStudio to process Sweave documents that embed R chunks with LaTeX. RStudio could not find the LaTeX distribution. TeXworks could, but I had configured it previously. It turns out that this Yosemite beta/RC has a known problem passing environment variables to processes. The apps never read the bash environment from .profile but one used to be able to use a csh syntax and set environment variables in /etc/lauchd.conf that many apps read/find. This does not now work for RStudio or another application (ImageJ) that I use. I did find a workaround - I can set the path and environment variables directly via launchctl from a bash shell script. Here are a couple of lines from the script in case it helps someone
> # fix-yos.sh
> launchctl setenv PATH /usr/texbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin
> launchctl setenv GIT_HOME /Users/jrminter/git 
> I run the fix-yos.sh from terminal prior to launching a problem application and my applications work.
> Hope this helps others.
> John Minter

TeX Live Utility also has a problem because of the environment problem in Yosemite.

Note: unless you are playing games with PATH in your .profile or have changed stuff in /etc/profile /usr/texbin should be added to the PATH automatically because of the files in /etc/paths.d. Sometimes a major OS upgrade removes those files. Installing /Applications/TeX/FixMactex2014.pkg should fix that and any problems with the /usr/texbin symbolic link.

You can use the enclosed scripts to change active TeX distributions until the TeX Distribution Preference Pane gets fixed.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: switch TL versions.zip
Type: application/zip
Size: 3064 bytes
Desc: not available
URL: <https://email.esm.psu.edu/pipermail/macosx-tex/attachments/20141005/d0372b7d/attachment.zip>
-------------- next part --------------

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the MacOSX-TeX mailing list