[OS X TeX] /usr/local/texlive/texmf-local/ls-R: Permission denied; MacTeX 2017/High Sierra

Rowland McDonnell rjmmnet-lists at yahoo.co.uk
Thu Nov 23 13:56:48 EST 2017


I've just installed MacTeX 2017 on macOS High Sierra v10.13.1

I want to add system-wide local additions, so I copied my usual 
system-wide additions to:


as I've done previously.

I followed the instructions here:


to set up my additional fonts for the new installation.  All 
files are in appropriate places, so I ran the following Terminal commands:

sudo -H mktexlsr
sudo -H updmap-sys --force --enable Map=local_extras.map
sudo -H mktexlsr

Everything seemed in order, so I tried LaTeXing a simple test 
document to verify that my locally-added package and fonts were 
available (one of which is Monotype Joanna):

\usepackage{joanna}% load Monotype Joanna and other fonts to match
Hello world.

This didn't work as expected - the locally-added ls-R file was unreadable:

/usr/local/texlive/texmf-local/ls-r: Permission denied
/usr/local/texlive/texmf-local/ls-R: Permission denied
This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017) 
(preloaded format=pdflatex)
  \write18 enabled.
entering extended mode
LaTeX2e <2017-04-15>
Babel <3.10> and hyphenation patterns for 84 language(s) loaded.
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class

! LaTeX Error: File `joanna.sty' not found.

I checked permissions etc on the file in question using ls -la:

-rw----r--   1 root     admin  38783 23 Nov 16:12 ls-R

Finder.app tells me that permissions on that file are:

system: Read & Write
everyone: Read only

I couldn't open the file in TextEdit. The Finder said:

The document “ls-R” could not be opened. You don’t have permission.

Just to check I wasn't missing anything obvious, I tried;

kpsewhich --var-value TEXMFLOCAL

which gave an output of:

/usr/local/texlive/texmf-local/ls-r: Permission denied
/usr/local/texlive/texmf-local/ls-R: Permission denied

I made a copy of the troublesome ls-R file using the Finder's 
File->Duplicate command and I could open that (filename: ls-R 
copy) without trouble in Textedit.app.  It's got the expected contents.

I then moved the ls-R file created by sudo -H mktexlsr and 
renamed ls-R copy to ls-R using the Finder.

My test document then LaTeXed exactly as expected.

I don't understand this problem since the mktexlsr created ls-R 
seems to have appropriate permissions as far as I understand it, 
but obviously the machinery thinks otherwise.

This looks like a problem which needs investigating - or have I 
done something wrong?

I'd appreciate any comments.


More information about the MacOSX-TeX mailing list