[OS X TeX] Problem compiling Spelling dictionaries

Richard Koch koch at uoregon.edu
Sat Jan 6 11:55:24 EST 2018


This is a problem I have seen in the past on earlier versions of OS X. But I did not run into it when I
installed on a freshly installed High Sierra. 

I just check the cocoAspell site and the latest version is 2.5, which is the version we shipped with
MacTeX-2017. So you should have the latest version if you installed using the copy in ~/Applications/TeX.

Anton Leuski's cocoAspell site is


and it has a comment that could be related to your problem. Here is the comment:

	• Some users reported that they are unable to configure or install the dictionaries. Generally, these problems can be traced to some modifications to the command line environment. For example, one user had his default shell set to csh and had some extra commands in .cshrcthat were confusing the dictionary installation script. I am looking to make the dictionary installation process more robust.

You might examine the system log file and see if anything was written there when you tried to install. Otherwise try
writing Leuski directly, although I should warn that he is working on other things and may not have time to

Dick Koch

> On Jan 6, 2018, at 8:22 AM, Marina Epelman <mepelman at alum.mit.edu> wrote:
> Dear all —
> I’ve been following a discussion on "TeXShop, Cocoaspell, and MacOS 10.13.2” yesterday, and I have a related issue. I just upgraded to 10.13.2 from 10.12, and concurrently upgraded from 2016 to 2017 distribution. I was trying to follow these instructions from Dick for installing and configuring Aspell:
>> a) This year for the first time, we supplied the CocoAspell install package in /Applications/TeX with MacTeX-2017. I found it there and installed with no problems,
>> b) Then I opened Apple's System Preferences and selected the new Spelling preference pane at the bottom. In the first column, I checked the first entry, English (United States) [w_accents]. On the right side, I checked the URL and TeX/LaTeX filters.
>> c) Next I ran TeXShop. In TeXShop Preferences, under the Source Tab, in the Dictionary pull down menu, I selected
>> English (United States) [w_accents] and clicked OK.
>> d) Then I restarted TeXShop. One of my documents automatically loaded, and tex command words were not marked as misspelled.
> However, when I got to step b) and selected the Spelling preference pane, I received the following error message: *Failed to compile “aspell6-en-6.0-0”* with further details: *The dictionary for “aspell6-en-6.0-0” has to be compiled before it can be used. The dictionary cannot be compiled because you do not have sufficient access priviliges to the directory “/Library/Application Support/cocoAspell/aspell6-en-6.0-0”.* I am doing all of this from an account with administrative privileges on my machine.
> Any troubleshooting suggestions will be much appreciated.
> — Marina
> ----------- Please Consult the Following Before Posting -----------
> TeX FAQ: http://www.tex.ac.uk/faq
> List Reminders and Etiquette: https://www.esm.psu.edu/~gray/tex/
> List Archives: http://dir.gmane.org/gmane.comp.tex.macosx
>                https://email.esm.psu.edu/pipermail/macosx-tex/
> TeX on Mac OS X Website: http://mactex-wiki.tug.org/
> List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

More information about the MacOSX-TeX mailing list