[OS X TeX] how install temporary, test version of a TeXLive file?

Murray Eisenberg murrayeisenberg at gmail.com
Wed Oct 2 17:49:29 EDT 2019

The only babel currently installed on my system is in /usr/local/texlive/2019/texmf-dist/tex/.

So I don’t know how to build all the needed files — given that I’m testing to see if this avoids a clash between babel’s french support and another package (crossreftools), I ought to install everything from this test babel.

I tried putting a copy of lthe latex docstrip.cfg in the same folder as the dowloaded (unzipped) babel distribution but changing it so as to use:


instead of the default.

But now when I run `latex babel.ins` I get a message that it cannot write to ~/Library/texmf/generic/babel/babel.log. Which is not surprising given that no subdirectory babel current exists in ~/Library/texmf/generic. 

So I seem to be stymied.

> On 2 Oct2019, at 5:29 PM, jfbu <jfbu at free.fr> wrote:
> Hi Murray,
> Le 02/10/2019 à 21:17, Murray Eisenberg a écrit :
>> To see if an incompatibility between babel and another LaTeX package has been eliminated in the latest, unstable, build of babel, the babel maintainer suggests I try this latest version.
>> How do I do that from the downloaded .dtx and .ins — WITHOUT overwriting the babel files currently in the TeXLive texmf tree and yet so that latex will be able to use this latest version?
>> If I simply cd to the folder holding babel.dtx and babel.ins and run latex babel.ins, immediately I get a request to overwrite a file in the previously-installed texmf tree.
>> What I want to do, if it will work, is put all the files needed in the same folder as my source document, so that I can test whether the incompatibility has bee cured.
> I know this will not be of any help to you but I too was interested in
> trying out the babel from github repo.
> I was confronted with same problem as you which I attempted
> to solve via editing by hand the ins file.
> But even after having done that I ended up with  a babel.sty (the only
> file I was interested in), which was unusable for me from containing
> Lua code
> I believe build is supposed to use lua, there is a build.lua script.
> In the end I simply "git diff" with the 3.44 version to identify
> the change I was interested in in file babel.dtx, and I copied pasted directly
> into a local copy of current babel.sty in my working repertory
> the relevant modification.
> I could then test succesfully the fix to the issue I was interested in
> (I think this is #30 in github repo, but it was closed without
> linking to the actual commit solving it ; not that that was
> a big riddle to solve as it was naturally the latest commit as of
> today in the repo :) )
> I know it does not help...
> Best,
> Jean-François
> ----------- Please Consult the Following Before Posting -----------
> TeX FAQ: http://www.tex.ac.uk/faq
> List Reminders and Etiquette: https://sites.esm.psu.edu/~gray/tex/
> List Archives: http://dir.gmane.org/gmane.comp.tex.macosx
>               https://email.esm.psu.edu/pipermail/macosx-tex/
> TeX on Mac OS X Website: http://mactex-wiki.tug.org/
> List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

Murray Eisenberg			murrayeisenberg at gmail.com
503 King Farm Blvd #101	Home (240)-246-7240
Rockville, MD 20850-6667	Mobile (413)-427-5334

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://email.esm.psu.edu/pipermail/macosx-tex/attachments/20191002/884d5343/attachment.htm>

More information about the MacOSX-TeX mailing list