[OS X Emacs] Switching from Carbon Emacs to Emacs.app

Lindsay Stirton Lindsay.Stirton at manchester.ac.uk
Sat Jan 5 08:14:07 EST 2008

Greetings, once more!

I decided to take Pete's advice, and to install AUCTeX directly. I seem 
to have
managed this, but with problems. Can anybody advise?

When I first tried to configure AUCTeX I got the following error


configure: error: Cannot find the texmf directory!
Please use --with-texmf-dir=dir to specify where the preview tex files go
configure: error: ./configure failed for preview

So I tried

Macintosh:auctex-11.84 ljs$ ./configure 

which seemed to work. However, after I finished the install, I get the 
when I try to LaTeX something.

Running `LaTeX' on `TMA01' with ``pdflatex  -interaction=nonstopmode "\input"
/bin/sh: pdflatex: command not found

LaTeX exited abnormally with code 127 at Sat Jan  5 13:03:30

Just to check, when I go back to using Enhanced Carbon Emacs, I can use 

As usual, any suggestions greatly appreciated.

Best wishes,

Lindsay Stirton

PS. My earlier problem with imaxima was solved with this in .emacs

  (setq imaxima-pt-size 12
        imaxima-fnt-size "Large"
        imaxima-use-maxima-mode-flag (locate-library "maxima"))

Quoting Peter Dyballa <Peter_Dyballa at Web.DE>:

> Am 05.01.2008 um 11:21 schrieb Lindsay Stirton:
>> 1. I tried to install Enrico Franconi's Enhanced Carbon Emacs.  Mostly, this
>> works OK but the Preview-LaTeX doesn't work. Here is a typical  
>> error message:
>> Preview-Ghostscript finished at Fri Jan  4 21:26:41
>> Running `Preview-Ghostscript' with ``gs
>> -dOutputFile\=\(TMA01.prv/tmp90158CBL/pr195-\%d.png\) -q -dSAFER - dNOPAUSE
>> -DNOPLATFONTS -dPrinted -dTextAlphaBits\=4 -dGraphicsAlphaBits\=4
>> -sDEVICE\=png16m -r110.522x110.836''
> This is no error message, it's just the report of the invocation of a 
>  helper application, gs (Ghostscript), to convert the pdfTeX output 
> of  the region marked to PNG format which then can be inserted in 
> place  of the LaTeX code marked.
> This fails for me too. I'll report the bug to AUCTeX and report later!
> BTW, IMO there is not much sense in using this plug-in. It comes from 
>  a time when AUCTeX was rather primitive. Meanwhile it has developed. 
>  Try to do your work without it! See what you can customise in AUCTeX 
>  instead!
> --
> Greetings
>   Pete
> Chicago, n.:
>         Where the dead still vote ... early and often!

More information about the MacOSX-Emacs mailing list