[OS X Emacs] Aquamacs: Latex does not work

Thomas Käufl kaeufl at ira.uka.de
Mon Mar 2 15:08:17 EST 2009

Hi David,

Am 2. Mrz 2009 um 13:39 schrieb David Reitter:

> ...
> The current nightly build (http://aquamacs.org/nightlies.shtml )  
> sets this as well.  So, you may have more luck with that.

Thank you for your help. Mentioning the login shell was the
hint which put me on the right track.

In /etc/profile I added the path to the TeX binaries, fired up
Aquamacs (with my customizations) and processed a Latex file. It
worked. (To be complete: First I removed the preferences of
Terminal and logged out.)

> Looking at the paths you sent me, it doesn't seem like your system  
> is configured to have /usr/texbin in the PATH, at least not the G4.
> ...

I had a problem with my Latex installation. In January I switched
to Mac-Tex and as far as I remember everything worked. Later,
I installed the most recent security update of Apple and a QuickTime
update too. After that, all pathes to the Tex binaries were broken.
I fixed that for the tc-shell (and forgot to use /usr/texbin).

My installation of Aquamacs 1.6 could not process Latex files
too. The reasons are unknown to me. Could (security) updates
of Apple be a problem?


More information about the MacOSX-Emacs mailing list