[OS X Emacs] Re: Re: Can't Make Doc-View Work

John Mark Swafford johnmarksuave at gmail.com
Thu Mar 11 18:37:56 EST 2010

Woah! Thanks for all the suggestions! So much to try... I'll start with what
I tried first.

>> This is the old Savannah site from whose 23.x sources you can't build a
"Carbon Emacs." What you have is either >> the X client or the Aqua/Cocoa
variant from the configure option --with-ns.
>--with-ns should be the default.

>Note however that he's built from an old source that is likely to be of Dec
27 2009.
>To get a current snapshot, the 23.2 prereleases should be used, or git or
bzr from the new repository.

I downloaded and installed git so I could get the newest version of Emacs. I
built Emacs by using the following:
git clone git://repo.or.cz/emacs.git
./configure --with-gif=no --with-ns
make install
sudo cp -r nextstep/Emacs.app /Applications/Emacs.app

With this fresh install, I switched off my .emacs and .elisp files and still
had the same problems as before.

>>> With "Carbon Emacs 23.1.90" you probably mean the "AppKit Emacs"
>>> by YAMAMOTO Mitsuharu, don't you?
>> I mean the build of Emacs I checked out using this: cvs -z3
>> -d:pserver:anonymous at cvs.sv.gnu.org:/sources/emacs co emacs. I
>> configured
>> and built this version and that's what I'm having a problem with.

>This is the old Savannah site from whose 23.x sources you can't build
>a "Carbon Emacs." What you have is either the X client or the Aqua/
>Cocoa variant from the configure option --with-ns.

>After this NS (from NeXT's NeXTStep and later OpenStep/GNUstep, which
>mutated to Mac OS X's Cocoa) variant was compiled, did you invoke
>"sudo make install?" Are you using this installation's Emacs.app?

Yes, I'm using the Emacs.app.

>>> Does this view switch when you type C-c C-c?
>> Kind of... When I start in my main.tex file and press C-c C-c, .pdf
>> code of
>> my latex document open in another buffer.

>Are you using AUCTeX here or GNU Emacs' own La/TeX-mode?

I'm not positive... When I have a .tex document open, it says [(LaTeX ht
Fill)] in the mode-line. I'm assuming this means I'm using GNU Emacs' own
LaTeX mode. I'll try and install AUCTeX and see what happens when I do

>You need Ghostscript for doc-view. And in case the DVI files are using
>CM (Computer Modern) fonts gs probably needs to find them via a local
>or TeX related Fontmap file. With PDF output from TeX it's probably
>less complicated...

I have Ghostscript and a number of other image/document converting apps. I
checked to make sure Emacs could see them by using the tex-shell inside
Emacs and typing:
which gs

This prints the correct directory where Ghostscript is installed. This
didn't work at first, but I added the right directories to my $PATH. That
solved that problem.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://email.esm.psu.edu/pipermail/macosx-emacs/attachments/20100311/2aaa9b4f/attachment.html>

More information about the MacOSX-Emacs mailing list