[OS X TeX] Another font installation question

Martin Stokhof stokhof at hum.uva.nl
Wed Jun 19 16:23:05 EDT 2002


Apologies for bothering you all with yet another problem concerning 
font installation. I've followed various of the discussions 
concerning this topic, and tried to guess from these discussions how 
to proceed, but I still can not get my Adobe Bembo fonts (Bembo 1, 
Bembo 2, Bembo Expert ) properly installed. This is what I've done.

I downloaded the bembo package in xadobe from CTAN. And I ran afm2tfm 
on the original afm files.

Then I made the following subdirectories in the local ~/Library/texmf tree:
-- /fonts/tfm/adobe/bembo , which contains the .tfm files I produced 
>from the afm files, and the. tfm files from the CTAN bembo package
-- /fonts/type1/adobe/bembo , which contains the .pfb files
-- /fonts/vf/adobe.bembo , with the .vf files from the bembo package

I ran texhash to update the various (sub)trees and then tried to 
typeset a small test file. Alas, with no succes. From what I can see 
in the .log file dvips can't find a file named "pbbb8r", although 
there is a pbbb8r.tfm, in the /fonts/tfm/adobe/bembo directory.

This is what I gess is the relavant message in the .log file:

>(/Users/martinst/Library/texmf/tex/latex/psnfss/xbembo.sty) (./bembo_test.aux)
>(./bembo_test.aux)kpathsea: Running mktexpk --mfmode / --bdpi 600 
>--mag 1+120/600 --dpi 720 pbbb8r
>/usr/local/teTeX/share/texmf/web2c/mktexdir: cd: too many arguments [31]
>/usr/local/teTeX/share/texmf/web2c/mktexdir: cd: too many arguments [34]
>mktexpk: Running mf \mode:=ljfour; mag:=1+120/600; nonstopmode; input pbbb8r
>This is METAFONT, Version 2.7182 (Web2C 7.3.7)
>kpathsea: Running mktexmf  pbbb8r
>! I can't find file `pbbb8r'.
><*> ...; mag:=1+120/600; nonstopmode; input pbbb8r
>Please type another input file name
>! Emergency stop.
><*> ...; mag:=1+120/600; nonstopmode; input pbbb8r
>Transcript written on mfput.log.

I'm probably overlooking something that has been mentioned already, 
but I must confess that I find the whole procedure rather 
complicated. So any suggestions as to what is wrong in my set-up 
will be greatly appreciated. Thanks in advance.

Martin Stokhof

Threaded list archives can be found at:
To UNSUBSCRIBE, send email to <info at email.esm.psu.edu> with
"unsubscribe macosx-tex" (no quotes) in the body.
For additional HELP, send email to <info at email.esm.psu.edu> with
"help" (no quotes) in the body.

More information about the MacOSX-TeX mailing list