[OS X TeX] latexit issues

dfen2752 at mail.usyd.edu.au dfen2752 at mail.usyd.edu.au
Sat Jun 14 09:43:23 EDT 2008

Thanks everyone for your help :) But no luck.

I removed the plist, and all the properties have been reverted back to
default. But no luck there. I've even tried downloading it from the
website, and reinstalling it, but it's still the same 'unexpected error'.

Jan, when you installed mactex, did you install all the bundled software
(texshop?) and all the extra modules (ghostscript and stuff)?

does latexit require any of the bundled software to run, because i didn't
install any of them...as Textmate is good enough for me.

it shows a different path because i changed the link in the preference to
the alias '/usr/texbin/pdflatex' to the file it was linked to. but that
changed it back now.

i've run the 'which' command on all the underlying programs (pdflatex, gs,
ps2pdf), and they all point to the correct location. (and no, it wasn't
obvious. i completely forgot about that command)

i get the exact same output when i run the ls -l command. all the
permissions seem fine as well.

The weird thing is that the error says "error while processing pdflatex",
but when i run 'pdflatex -file-line-error -interaction nonstopmode' on the
temporary file from terminal, it works. This is the ls dump of the
temporary folder:

-rw-r--r--  1 derek  staff   307B 14 Jun 23:41 latexit-1.tex
-rw-r--r--  1 derek  staff    70B 14 Jun 23:16 latexit-paths

Are those file permissions correct? I'm stumped for ideas.



This message was sent using IMP, the Internet Messaging Program.

More information about the MacOSX-TeX mailing list